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SUPERPRO INTERFACE SOFTWARE

Version 1.0 Release notes

Version 1.0 includes programs for programming PAL's,
GAL's, PROM's, and Single microcontrollers. Aiso this can
test TTL & CMOS logic chips and RAM's.

The new features of these programs include support for
JEDEC files created by many compilers and an entirely new
user interface. The programs feature a puil-down menu
interfface which allows operation of functions from the
menus, by typing in the key letter of each command. Typing
the first character of the menu is convenient to select the
menu of interest instead of highlighting and pressing the
return key. (Thus it was inevitable to use the non overlapping
middie character when the two menus have the same first
characters. The on-screen prompt lines assist your selection
of options.

Attached to these release notes are newly lllustrated
chapters for the SUPERPRO reference manual which fully
document the operation of most of the programmable chips.
This manual is consisted of three parts: Book |, Book I, and
appendixes. Book | will explain the general informations
such as system requirements, getting started, and etc. In
Book |l the detailed Information about the each menu will be
given. In the appendixes data format, customer support,
customer and the method of self-maintenance will be
described. So | suggest quick readers must read Book |, but
refer to Book Il as necessary.

In this manual, only regular version of SUPERPRO will
be explained. The algorithm generator will approach the
users in a different package. The algorithm generator has the
power to update new devices.



Contents

BOOK |

INTRODUCTION
1 What Is SUPERPRO?
2 Manual Organization
3 Manual Conventions

REQUIREMENTS
1 Hardware and Software
2 DOS Considerations
3 SUPERPRO Package
4 Files on the Release Disk(s)

GETTING STARTED
1 A Checklist
2 Creating Backup Copies
3 Installing Hardware
4 Installing Software
4.1 Setting DOS Path
5 Running Software
6 Possible Errors

PROGRAMMING
1 TTL & CMOS (RAM)
2 PROM & Microcontroller
3 PAL & GAL

Chapter 1
1-1
1-3
1-3

Chapter 2
2-1
2-1
2-2
2-2

Chapter 3
3-1
3-1
3-2
3-4
3-4
3-4
3-5

Chapter 4
4-1
4-2
4-2



CONTENTS

BOOK I

FILE

1 Load
1.1 Loading a JEDEC file
1.2 Loading a HEX file

2 Save
2.1 JEDEC fuse map load
2.2 HEX file load

3 Directory

4 User Screen

5 DOS/SHELL

6 Quit

BUFFER

1 Edit
1.1 HEX file buffer

1.2 JEDEC fuse map buffer

2 Checksum
3 Fill
4 Vector Table
5 External
5.1 MES Edit
5.2 Encryption Table
6 UES Edit

MANUFACTURER

1 Manufacturer
2 Type
3 Default Device Format

DEVICE

7]

1 Function Select
A Function Field
B.Repeat Field
C.Message Field
D.Address Field
E.Environment Field
2 Gang & Word Format

Chapter 1
1-1
1-2

Chapter 3
3-1
3-1
3-2

Chapter 4
4-1

4-3

4-13

4-14

4-14

4-15

4-16



CONTENTS

TEST
1 Edit Pattern
2 Append Pattern
3 Delete Pattern
4 TTL & CMOS Test
5 Auto Find Device
6 Memory Test
7 Vector Test

MACRO
1 Begin
2 End
3 Load
4 Save
5 Batch Make

OPTION

1 Interface Port

2 Directory

3 Environment
3.1 HEX Load Method
3.2 Blank Char
3.3 Mulriplw Load on
3.4 Batch File Name
3.5 Macro Delar Time

4 Load Configuration

5 Save Configuration

APPENDIX

A. JEDEC FILE FORMAT
B. HEX FILE FORMAT

C. CUSTOMER SUPPORT
D. SELF MAINTENANCE

Chapter 5
5-2
5-2
5-3
5-3
5-4
5-4
5-4

Chapter 6
6-2
6-2
6-2
6-2
6-3

Chapter 7
7-2
7-2
7-3
7-3
7-3
7-3
7-3
7-4
7-4
7-4

i



BOOKI|

This part will introduce the
SUPERPRO, explain the
requirements of system, and let you
get started. In the Chapter 4, there
are quick guide line about
programming various kinds of chips.
For quick readers, it is suggested to
use the Chapter 4 as an itinerary line
and Book |l as a detailed map for
programming.



1 INTRODUCTION

Congratulations on your purchase of the
SUPERPRO universal programmer! To protect your
investment in the SUPERPRO hardware and
software, be sure to fill out and return the
Registration Card enclosed with the package.
Registration is required for warranty service and
notification of software updates.

1. What Is SUPERPRO?

The SUPERPRO is an affordable, reliable, and extremely fast
universal device programmer. The SUPERPRO is designed to
operate with the IBM-PC/XT /AT /386 series of computers and their
compatibles. The SUPERPRO’s menu-driven, interface software
makes loading, editing, and downloading files easy to use.
The programming hardware includes the following features:

= The sleek, low-profile programming module includes a 40-pin
ZIF socket, for programming and testing 8-pin to 40-pin
devices, a "busy" LED indicator, and a "good" LED Indicator.

= The SUPERPRO's high-speed, parallel interface card, when
plugged into your PC expansion slots, speeds the uploading
and downloading of files.

= Device models that are PC-resident in software permits easy
updates by diskette.

m  Protection for short circuits
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m Hardware timer in the programming module ensures correct
programming time.

s Four E(E)PROMs may be programmed serially with optional
four socket adapter. This saves time for mounting one by one.

m Four layer PCB design for outstanding apperance and nolse
reduction.

The SUPERPRO interface software includes these features:

s The utmost capability of updating chips of SUPERPRO
advanced version.

m An easy-io-learn user interface, including pull-down menus,
selection and entry boxes, and on-line help prompts.

m Integrated text editors for modifying JEDEC files and test
vectors.

= Programming support for a large list of devices, including the
most popular manufacturers of PROMs, EPROMs, EEPROMSs,
PALs, PEELs, PLDs, EPLDs, and GALs. [C testing capability
for TTL, CMOS, and memory devices.

m The contents of E(E)PROMs, PALs, GALs, Bipolar PROMs,
and 8748/51 series single-chip CPU’s, can be read and saved
onto disk.

= Displayed CHECKSUM and BLOWCOUNT assures correct
programming of parts.

s Vector testing s avalilable to test functions for PAL devices.

s Intel (extended) HEX, Motorola $1, 2, and S$3, and Tektronix
(extended) format files will be loaded, and are automatically
converted to BIN format.

This document explains how to Install and use your SUPERPRO
programmer and Interface software. We hope you will enjoy using
our products, and that they will help you create high-quallty,
programmed devices quickly and efficiently.
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2. Manual Organization

The SUPERPRO Reference Manual consists of three main parts:
Book |, Book |, and Appendixes.

Book I.: Chapters 1-4

An introduction to the SUPERPRO, including features, system
requirements, set-up of the hardware and software, and brief
instructions for programming various kinds of chips.

Book Il : Chapters 1-7
Detailed operating instructions and menus for each of the software
routines are explained.

Appendixes : A-D
Information on the JEDEC file format, HEX file format, XELTEK
customer support, and self maintenance.

3. Manual Conventions

The following conventions are used In this manual:

1. The names of all non-alphanumeric keys and key sequences
are enclosed in angle brackets < >. For example, the Enter
(or Return) key is shown as <Enter>; the PgUp (Page Up)
key is shown as <PgUp>.

The cursor keys are shown as follows:
Left arrow key = <LeftArrow>

Right arrow key = <RightArrow>

Up arrow key = <UpArrow>

Down arrow key = <DownArrow>

2. Al text that appears on the screen Is shown in bold
characters. These characters are elther manually typed or
are displayed by the program. For example:

sp

3. The keystroke <Enter> Is pressed at the end of each DOS
command and will not be shown in the manual.

1-3



CHAPTER 1

Unless stated otherwise, keystrokes are not case-sensitive.
This means that you can enter either upper-case or lower-
case characters. For example, if you are asked to type the
letter A, you can type either A or a.

The manual refers to a menu selection inside a quotation
mark. The sub levels will be indicated by an arrow. For
example, referring to the Macro delay time inside the menu,
Environment which is again the submenu of option will be as
follows. Select "Option -> Environment -> Macro delay
time". This tells the users to go to the menu of option and
select the submenu, environment and finally select Macro
delay time.

The manual includes WARNING and NOTE paragraphs, which are
indented and printed in italics. A WARNING refers to information that
can prevent damage to hardware or software, including Irretrievable
loss of your data files. A NOTE contains additional topic information
and recommendations.



2 REQUIREMENTS

1. Hardware and Software

The minimum hardware requirements for using the SUPERPRO
hardware and software are as follows:

IBM-PC/XT /AT /386 computer or compatible.

Open Slot. A minimum of one halfdength slot for Inserting
the parallel interface card.

640 Kbytes RAM.
MS-DOS or PC-DOS, Version 2.1 or greater.

One Disk Drive. One diskette drive (360Kbyte, 720Kbyte,
1.2Mbyte or 1.44Mbyte) for copying and saving program and
data files, and optionally one hard disk drive for operation.

Color or Monochrome Graphics Adapter and Monltor. The
SUPERPRO software operates in text mode and supports all
graphics devices, color, or monochrome.

2. DOS Considerations

This manual assumes you are familiar with the Disk Operating
System (DOS) of the computer. Standard operations such as disk
formatting, copying files and disks, listing directory files, and so on,
must be understood to be abie to run the SUPERPRO software. You
may wish to refer to a DOS manual, your computer's operating
manual, and other tutorial and reference documentation on the set-
up and use of your computer.
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3. SUPERPRO Package
Your SUPERPRO package contains the following:

s The SUPERPRO programming module.
2 The haif-siot paraliel interface PCB card.
s A parallel interface connecting cable.

# The SUPERPRO Reference Manuai.

e The SUPERPRO software diskettes.

= One Registration Form. This form should be filled out and
returned as soon as possible. Registration is required for
warranty service and notification of software updates.

s One Device Update Coupon. Use this coupon to request
support for new programmable devices.

4, Files on the Release Diskette(s)

There will be one system diskette and one or more algorithms
diskettes.

System diskette A\install. bat
A\sp.exe
A:\sphelp.hip
A:\lib\*.lib
A:\lib\tti.lib

One of more algorithm diskette(s) contain(s) files with “lef* suffix.

2-2



3 GETTING STARTED

1. Checklist

The following checklist shows the steps required to run the
SUPERPRO programmer. Each step is explained in detall in this
chapter.

s Make backup copies of the SUPERPRO software diskettes.
s Install the SUPERPRO software in a directory on the hard disk.

= Install the SUPERPRO interface card properly in your personal
computer.

s Connect the programming module to the installed interface
card with the provided cable.

s Power up the programming module.

s Run the SUPERPRO software routines to load, edit, and
download files to the programmable device.

2. Creating Backup Copies

We strongly recommend that you make backup copiles of the
SUPERPRO diskettes, then use these backup diskettes to install
the software. Computer diskettes are not indestructible. They can
incur damage from any number of calamities, such as drive
problems, mishandling, coffee spills, and curious pets.

All SUPERPRO programs and files are stored as standard DOS files.
There are no copy-protection schemes such as hidden files or
corrupt sectors on the diskettes containing the software. It is a
simple matter to make any number of backup copies using the DOS
COPY command.

3-1
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To backup your diskettes, first format an equal number of new
diskettes. Now copy the files on each SUPERPRO diskette to a
newly formatted diskette. Label the backup coples with the same
names given to the original diskettes, and use them as your working
coples of the software. Store the original SUPERPRO diskettes In a
cool, dry place, away from magnetic fields and direct sunlight.

3. Installing Hardware

The SUPERPRO universal programming hardware consists of a
desktop programming module with 40-pin ZIF socket, a parallel
interface card, which fits in a short slot in your computer, and a
parallel interface cable to connect the programmer to the interface
card. The programming module derives its power from the PC via
the parallel interface; thus, no additional power cord Is present.

The first step is to Install the interface card in your PC. Turn your
computer off and carefully remove [ts cover. Check the
documentation with your computer and the interface cards to be
sure that the port address set in the SUPERPRO interface card does
not conflict with any existing |/O devices. The default setting from
the factory is at jumper position #5 which corresponds to port
address 280-29F.

If an address change is necessary, relocate the jumper position
according to the following table:

Jumper Position 1/O Address (Hex)
#1 . 200-21F
#2 220-23F
#3 240-25F
#4 - 260-27F
#5 280-29F (Default)
#6 2A0-2BF
#7 ' 2C0-2Df
#8 2E0-2FF

3-2
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Jumper Positions —\

——
B 5 N 1 |
% [:l Connect to
Programming
Module
E— C———

QOO0 OO0

Figure 3.1 SUPERPRO parallel interface card

If you changed the jumper position on the interface card, you may
have to change the port address information within SUPERPRO
software routine. When you first run the program, for instance, a
communication error will be issued because the software Is set up
initially to access the programming module via the default address,
280-29F. SUPERPRO routine includes a command to reset the port
address, which should resolve the problem. To change the port
address, ignoring the communication error message press <return>
and select "Option -> Interface port'. Then select the desired
address.

Once you have the jumper set as desired, carefully insert the card
into an open slot in your computer, screw the bracket down securely
to your computer’s chassis, and replace the cover.

Now connect the parallel interface cable to the programming module
on one end, and connect the parallel interface card connector to the
back of your computer. Now turn on your computer, then the
programmer. You are now ready to begin!



CHAPTER 3

4. Installing Software

We recommend a hard disk installation to speed access to your flles.
After loading DOS, make sure that drive C (the hard disk) is the
default device. The following prompt should be displayed:

c>

Insert the system diskette and type install. After the creation of BIN,
LIB, and ALGO, system disk will be copied in the directory BIN, and
Library will be copied under LIB. Then it will ask for the next diskette
to be inserted until there is no diskette left.

4.1. Setting DOS Path

By setting the DOS PATH variable (described in detail in the DOS
Manual), you can run the SUPERPRO software from any directory.
You do not have to be in the \SUPERPRO directory to execute the
program.

To set the DOS path, assign the pathname \SUPERPRO to the PATH
variable. This is usually done in the AUTOEXEC.BAT file, so you do
not have to set the path each time you turn the computer off and on.
A typical PATH variable assighment is shown below:

PATH=C:\DOS;C:\UTIL;C:\SUPERPRO

In this example, whenever a program or batch file is invoked, DOS
searches for it in the current directory. If the operating system can't
find the program or batch file in the current directory, it searches all
directories listed in the PATH setting.

5. Running Software

In general, you should always turn ON the SUPERPRO programming
module before starting any of the software routines, to avoid the
communication error. The regular version will not include ag and Ig
software. The advanced version will be sold separately for the users
who want to update devices by themselves.

34



GETTING STARTED

To program all kinds of devices in the advanced version of
SUPERPRO, type :

sp (abbreviation of SUPERPRO)

To update devices in the advanced version of SUPERPRO, type :
ag (abbreviation of Algorithm Generator)

To manage the database in the advanced version of SUPERPRO,
type :

Ig (abbreviation of Library Generator)

6. Possible Errors

A communication error may also occur if a device is locked In the
programmer’s ZIF socket when invoking any of the SUPERPRO
software routines. Just be sure the socket is empty when Invoking
any of the routines. Once the menu is on the screen, you can lock
socket by pulling down the lever.

As noted above, a communication error may also occur if you have
changed the port address on the interface card. Match the port
address within the SUPERPRO software routine to the setting of the
interface card.

3-5



4 PROGRAMMING

This chapter will be devoted in explaining the menu selection for the
various kinds of devices. Thus, a general way of selecting menus for
programming will be discussed without much details. For the details
in question please refer to any relevant Chapter of Book Il which
explains the menus in details.

1. TTL & CMOS (RAM)

The SUPERPRO can test logic IC and RAM memory devices and
vector testing. A menu-driven software program provides an easy
interface for loading files, editing test patterns, and downloading test
files to the device. TTL.LIB Contains the TTL and CMOS test patterns.
The following checklist shows the steps required to test the Logic
IC’s and RAM’s. To test logic ICs and RAM memories, be certain that
the SUPERPRO hardware is properly installed, and that the
programmer is turned on.

A. Set up the interface card into the EMS (Expansion Memory Siot)
and connect the programmer to the computer by the cable
provided. Turn on the computer and invoke the software by
typing “SP". Mount the device of interest on the 40 pin DIP socket
of SUPERPRO. For details on instaliation, please refer to Chapter
d.

B. From the screen, select the "Test->TTL & CMOS Test" and press
the return key. This menu can also be selected by pressing “Ctri-
F4."

C. Enter the device name in the box provided. If the device is not
found in the library of TTL.LIB, an error message will be displayed.

D. Upon pressing <return>, test result will be dispiayed.

41



CHAPTER 4

For RAM testing, follow the procedure exactly, but in B select "Test -
>Memory test.”

2. PROM (Bipoiar, CMOS, NMOS..) and Singie
Microcontroller

A. Set up the interface card into the EMS (Expansion Memory Slot)
and connect the programmer to the computer by the cable
provided. Turn on the computer and Invoke the software by
typing "SP". Mount the device of interest. For detalls on
installation, please refer to Chapter 3.

B. From the main screen, go to "Manufacturer->Default device
format.” and select "ROM" in the submenu.

C. Go to "Manufacturer->Manufacturer” and select by typing the
name of manufacturer or <return>, to dispiay all the
manufacturers. When all the manufacturers are displayed,
highlight the right manufacturer and press the return key to select.

D. Go to "Manufacturer->Type" and select the part name of a chip by
either highlighting or typing.

E. Go to "File->Load" and load a HEX file.

F. Go to "Buffer->Edit" and check the data file.

G. Go to "Device->Function select”, a big subscreen Is displayed.
Highlight a function desired and execute. To move between

blocks in the screen, press Alt and the capitalized character of the
head title of the block.

3. PAL & GAL

A. Set up the interface card into the EMS (Expansion Memory Siot)
and connect the programmer to the computer by the cable
provided. Turn on the computer and invoke the software by

4-2
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typing "SP". Mount the device of interest. For the details of
installing, please refer to Ch 3.

. From the main screen, go to "Manufacturer->Default device
format." and select "PLD" in the submenu.

. Go to "Manufacturer->Manufacturer" and select by typing the
name of manufacturer or just return to display all the
manufacturer. When all the manufacturer displays highlight the
manufacturer and press return key to select.

. Go to "Manufacturer->Type" and select the name of a chip by
either highlighting or typing.

. Go to "File->Load" and load a JEDEC fuse map file.

. Go to "Buffer-> Edit" and check the data file.

. Go to "Device->Function select", a big subscreen Is displayed.
Highlight a function desired and execute. To move between
blocks in the screen press Alt and the capitalized character of the
head title of the block.

. For Vector Testing, go to "Test->Vector test”, and perform vector
testing.

4-3
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This describes all the menus and
their submenus. This is consisted of
seven Chapters which are the root
level menus seen in the main
screen. The left most menu "File" is
Chapter one and the right most
- menu "Option" is Chapter seven.



1 FILE

This menu deals with file management and system interfacing.

. | g B

__________________ 0 fie! NORD FORMAT
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Figure 1.1 File Menu

1. Load

Primarily, files can be categorized into two kinds, one Is JEDEC fuse
map file format and the other is HEX file format. This menu will deal
with both. In both cases wildcard characters such as * and ? will be
accepted. If you use wildcards the range of files specified will be
displayed, then highlight the portion and press return key for loading.

The reserved key "F3" will bring out this menu from any menu and at any
time.
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CHAPTER 1

1.1. Loading a JEDEC file

This loads a JEDEC file from disk to the buffer if "Manufacturer-
>Default Device Format -> Fuse" is selected. A box for the name of
the JEDEC file to be loaded will be displayed. Error message will be
displayed for non JEDEC fuse map files.

-m—!mseﬁﬂ '~ il

I a—
E;q::hg; |12 LI

il - B | T Sl ute

Figure 1.2 Menu for JEDEC file

1.2. Loading a HEX file

This loads a HEX file from disk to the buffer. The format selected has
to be the same format as the HEX file. If not, loading of the HEX file
will not be successful. The following formats are supported by the
programmer:

Sub Menus ;

A:Binary file B:Intel(Extended)
C:Motorola S1 D:Motorola S2
E:Motorola S3 F:Tektronix

G:Extended Tektronix



FILE

The reserved key "F3" will bring out this menu from any menu and at any
time.

A. Binary File : Multiple Loading

Loads the binary data into the buffer from the disk. Multiple loading is
possible if "Config->Environment->Multiple Load" menu is set "on".
In this mode submenus will be displayed, and by speclfying the start
addresses it is possible to load many files in the buffer. Multiple
loading is possible with HEX files since Superpro can save any file
into binary format after loading HEX files into the software.

Sub menus ;

Running : Initiates the execution
File name : Takes a file name to save
Start address : Start address of the buffer

s
Y;?‘ur;ao?i om
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Figure 1.3 Multiple Loading set "ON"
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If “"Config->Environment->Multiple Load" - menu is set "off,
Submenus will not be displayed. Only a box for a filename will be
displayed as in the figure below.

ion
ornation
oET

surmmn}:ss E%tgrl‘ﬂ“ i . égﬁﬁ‘iﬁ; "

R R et Disk srace : 1116160 U

Figure 1.4 Multiple Loading Set "OFF"

B. Intel (Extended) HEX file load
C. Motorola S1 HEX file load

D. Motorola S2 HEX file load

E. Motorola S3 HEX file load

F. Tektronix HEX file load

G. Tektronix Extended HEX file load

1-4
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2. Save

Saves the file in the buffer which has been created, loaded from disk,
modified, or read from a chip onto a specified disk. Being similar to
the menu "File ->Load", this is used for two kinds of savings: JEDEC
fuse maps and HEX files.

The reserved key "F2" will bring out this menu from any menu and at any
time.

2.1. Saving JEDEC fuse map file

If PLD is chosen in the menu of "Manufacturer->Default Device
Format" a box for the name of the JEDEC file to be saved will show
up. If there is a file existing overwrite protection message will be
displayed.

b 1 [ . e

ORS¢ BBRE || Disk space ¢ 1itéiée BT e

Figure 1.5 JEDEC file saving
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2.2. Saving HEX file

If ROM is chosen a submenu which has different HEX file formats will
show up as below.

Sub menus ;

: Binary file

. Intel (Extended)

: Motorola S1

. Motorola S2

: Motorola S3

. Tektronix

. Extended Tektroni

OGMMmMOoOOm>

~ Inforaation.
¥1xeé Ynfnrnatlnn
\SER

tle Name
Buffer start address
Save size

Figure 1.6 HEX file saving

All seven menus have the same submenus and the usage Is identical.
They are explained below.

Sub menus ;

Running : Initiates the execution
File name : File name to be saved
Start address : Buffer address to start



FILE

Buffer size : No. of bytes to be saved
CAUTION: When specifying the buffer address, the number of bytes to be
saved is one byte greater than the difference between the last address and

the first address. For example, to save the content from Oth byte to 7th
byte, the buffer size should be 8.

3. Directory

If a directory is specified, the files in that directory will be displayed.

4. User Screen

It displays the screen just before you enter the software. Typing any
key will return to the software.

The reserved key "Alt-F5" will bring out this menu from any menu and
at any time.

5. DOS/SHELL

This allows the user to switch easily between the SUPERPRO software
and DOS. To switch to SUPERPRO software from DOS, type "exit".

Caution: If you invoke other software, be sure to close the software before
typing "exit" to get back to the programmer’s menu.

6. Quit

Returns back to the operation system. The reserved key "Alt-X" will
bring out this menu from any menu and at any time closing the
program and returning the cursor on DOS.

The reserved key "Alt-X" will bring out this menu from any menu and
at any time.



2 BUFFER

The buffer contains the data from the JEDEC file, HEX file or a master

chip.

1. Edit

Views and edits the data loaded in the buffer.

Sub menus ;

Edit
Checksum
Fill

Vector Table

External

Special Area

The reserved key "F6" will bring out this menu from any menu and at

any time.

1.1. HEX file buffer

If "Manufacturer->Default Device Format->ROM" Is selected, The
buffer for HEX data will display.

Arrow
Ctrl-N
Ctr-E
Ctrl-Z
PgUp
PgDn
Home
End

Ctrl-Home

Ctrl-End

Ctr-PgUp :

Left,right,up or down

Moves the cursor to the address you specified
Scroll up one line

Scroll down one line

Page down

Page up

To the beginning of a line

To the end of a line

To the beginning of a screen
To the end of a screen

To the beginning of the buffer
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Ctr-PgDn : To the end of the buffer

TAB : Switches back and forth between ASCIl and
HEX fields

ESC 2 Exits out of the buffer

1.2. JEDEC fuse map buffer

If "Manufacturer-> Default Device Format->PLD" Is selected, the fuse
map will be displayed. Editor keys are same as those for the HEX
editor buffer with some differences listed below.

1 Logic high
0 Logic low

2. Check Sum

If "Manufacturer-> Defauit Device Format->ROM" Is selected, the four
least significant HEX digits from the sum of all the data will show up
to accommodate quick comparisons.

The reserved key "Alt-F9" will bring out this menu from any menu and at
any time.

Submenus ;

Running : Initiates the execution
Buffer start address  : Start address
Buffer end address : End address

If "Manufacturer->Default Device Format->PLD" Is selected, a box
for the check sum and the blow count will be displayed the lower left
corner.

The reserved key "Alt-F9" will bring out this menu from any menu and at
any time.
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"""""""""" Disk space | 1116168 SERLT: fute

Figure 2.1 Checksum

2-3



CHAPTER 2

3. Fill

When “"Manufacturer->Default Device Format->ROM" Is selected,
this fills the desired value in HEX on the specified portion of the
buffer.

The reserved key "Alt-F10" will bring out this menu from any menu and at
any time.

Sub menus ;

Running on

Buffer Start Address
Buffer End Address
Fill Data

. Initiates the execution
: Filling starts

: Filling ends

: Data to be filled

i "Manufacturer->Default Device Format->PLD" Is selected, the
content of the buffer will be filled with blank characters.

o il [
E“T i émﬁg;g;;m
Disk space ¢ 1116169 T e

2-4

Figure 2.2 Fill menu
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4. Vector Table

This menu only applies when "Manufacturer->Default Device Format-
>PLD" is selected, This loads the test vector file from JEDEC files
into the buffer automatically if there is a vector test file in the JEDEC
file. Press T to perform Vector testing.

The reserved key "Alt-F8" will bring out this menu from any menu and at
any time.

rha v1on,
nfornation

Special area s i FHz

e O i
b 1 g e -

Figure 2.3 Vector Table

Editor Keys are as followed.

: High impedance state

: Don't care state

: Vec and Ground, and not tested output pins
: Output Logic High (VOH)

: Output Logic Low (VOL)

: Clock pin

: Input Logic High (VIH)

: Input Logic Low (VIL)

Arrow : Left,right,up or down

Cirl-N : Moves the cursor to the required address

OO ITZ XN
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Ctrl-E
Ctrl-Z
PgUp
PgDn
Home
End
Ctrl-Home
Cird-End
Ctrl-PgUp
Ctrl-PgDn
TAB

ESC

T

=]

: Scroll up one line

: Scroll down one line

: Page down

: Page up

: Go to the beginning of a line

: Go to the end of a line

: Go to the beginning of a screen

: Go to the end of a screen

: Go to the beginning of the buffer
: Go to the end of the buffer

: Toggles between ASCIl and HEX fields
: Exits buffer

. Activates vector test

T T
A

WORD FORHAT

S
WL § e End, ol Fobn 8

2-6

Figure 2.4 Vector Edit Buffer
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5. External

This applies to only GAL and Single chips. For GAL this Is used for
MES and UES read. For microcontrollers, it is used for encryption
tables.

The reserved key "Alt-F7" will bring out this menu from any menu and at
any time.

Edit
Checksun
Fill

Usctor table
& [l

Figure 2.5 External

5.1 MES Edit

MES (Manufacturer Electronic Signature) is the device information
defined by the manufacturer. The MES contains the following
information:

Cycle counter No. of programmings done to the device.
Algorithm revision Provides the necessary parameters for
programming

2-7
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Master Bit 1 means master, and 0 means non master.
When programming or erasing a master
device it displays a warning message.

Device code 8-bit code assigned to a device. (For
example, RAL18H4 [code = 27])

Manufacturer’s 1D 1D for an individual manufacturer.

5.2 Encryption Table (for single chip)

This menu deals with encryption table management.

ASCIT value

AR NN AN Y]

||||||||||||||||

£ 3l Sl AL Sl Ml HL 3L S %

£ 2t 3t Ml el il 7L S %

P Al it A ML S AL St ik 5

£ 3 ML ML FL 3

Qrl W Bew agdress,  IAB Chapse AOE ) Cort pulp  Ctrl_Pabn

Figure 2.6 Encryption Table

A. Load : Loads a file into the encryption table.

@

Save : Saves the content of the encryption table in disk.

C. Edit : Views and edit the table. Encryption table can be edited
by arrow key, home, and End key. The size of the default table
is 32 bytes. Only HEX values will be accepted.

D. Encryption table on/off : If this mode is on, the data read will
be Exclusive-NORed with the data in the encryption table. The
outcome will be displayed in the buffer.
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E. Encryption table size : Normally, the size of the encryption
table is 32 byte, but it differs a little depending on the device.
Only HEX values will be accepted.

6. UES Edit (Special Area)

UES (User Electronics Signature) EDIT s used to edit the information
in the UES information area. UES editing Is also possible In the fuse
map buffer. The UES is 64 bit long and can contain information like
socket location, program pattern revision, design revision, and etc.
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3 MANUFACTURER

This menu is used to choose the IC manufacturer and the device
type. Also, this menu will set up the environment for the chip type
selected.

Sub menus ;

Manufacturer

Type
Device format

The reserved key "F7" will bring out this menu from any menu and at any
time.

1. Manufacturer

This defines the IC manufacturer. To see the list of all the
companies, type *, highlight the entry and press the carriage return.
Or, specify the name of the company and return.

The reserved key "F7" will bring out this menu from any menu and at any
time.

2. Type

After the selection of the manufacturer, the device type is selected. If
users return, not typing any characters, a group of devices will be
displayed. If PLD is selected in "Manufacturer->Device Default
Format", all the PLD's will show from the manufacturer selected, and
if ROM then ROM’s will show up. However if ALL is chosen then all
the devices will be displayed.

The reserved key "F8" will bring out this menu from any menu and at any
time.
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3. Default Device Format

This menu sets the mode for PLD, ROM and ALL. Depending on the
mode, different submenus will be displayed.

The reserved key "F9" will bring out this menu from any menu and at any
time.

E,E?f N ] o

__________________ ‘g L. .

Wsm m Disk space | lliai‘;" } EWT' Tm

Figure 3.1 Default Device Format



4 DEVICE

This menu deals with the management or manipulation of the device.

There are three submenus, Function Select, Word Format, and Gang
Select.

1. Function Select

This menu will display a screen for all the pertinent information for
programmings. There are five fields such as functions, message,
address, repeat, and environment. Each field will be explained below.

T Tile BiTer Manitactuver BIYITTS Test TR
L
! B M,
— i — bl —
PR o ¢ 45" - Pa WG ALTER
TERE TR
------------------ E?SYE?Teé A " hom FoRT
Ecrs : paag | |-—arch File! ST hute
?ﬂou | B42490| | Disk space ! 3867984 :
AT T T T - P P T T 120 T

Figure 4.1 Function Select
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A. Function field

Users can perform all the possible functions for implementing
devices such as programming, reading, verifying, blank-check, data
comparison, automatic programming, encryption and security
programming.

B. Repeat field

Repeat, Delay, and Count will be recorded.

C. Message field

Error message or programming result will be displayed.

D. Address field

The informations about the chip and buffer address, current address,
and the gang number selected will be displayed.

E. Environment field

The information such as check sum, the number of gang selected,
the way of byte splitting for programming, the name of a
manufacturer and the part name of the device selected wil be
displayed.

Note: There are only three fields which are necessary to be accessed. They
are fUnctions, Repeat, and addrEss. To go into the each section users
need to press Alt and the capitalized character of the section title wanted.
For example to change the start address of the buffer for programming
users have to go into the address field and type over the start address field.
To go into the address field users must press Al-E.
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A. fUntions

1. Program

This downloads the data in the buffer onto the chip. The size of the
‘buffer is 64k bytes ranging from 0 ~ OXFFFF. "Verify" function will be
performed after programming. If there is an error the error message
with the address where the error occurred will be displayed. Any
other result will be displayed in the message section.

Tlhc tioms msage
Progra FESULT @ SUCCESS

Erase DK!
rogran OK!
lerification OK!

Current ADDR @ AABASEA9
Currenﬁnvgnﬁ il

1rnnnen1

M |
it
EEEE‘%T s

{ Use Alt-U or R or b |

T TELe Ihoranction select TO-EL 17 -Hawifacturer F8-lupe ]
Figure 4.2 Program (PAL/GAL)
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In the "addRess" section the address will be increased while the chip
is being programmed or verified. The start address and the end
address of the buffer can be corrected in the addrEss section.

| File Burrer Panuractuver WITIDLM Test HHcro Uetion gaus; 0aieh |

{[Tunciion sela l-'! i
TN | FESULT | SUCLESS ip Slart
T ogra e i tart
Tt T R i
ify rogran OK! uffey Start |
zmxic{mck {fer?ﬁcaﬁnn oKt Euf‘f‘er End SW
&Ih‘} e Current ADDR : ABRIFTAD
e ; Current Gang 1
CHIP Enviyonnent
~~~~~~~ : ]
Start ' A70dl8
End 1T}
BUFFE
------- Repeat
%tirt epaat ;
i a‘i '
------- ol TSl (se AlE-U or K or E |
CHECKS

IGArmER T e o e e

Figure 4.3 Program (ROM/Single)
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2. Read

This reads the content of a chip into the buffer. After reading is done,
in the address section, the checksum of the data will be displayed. If
the chip is a PAL or GAL the blow count will be shown also.

When a GAL is programmed the device should match the
manufacturer and the part name selected by the software. Otherwise,
an error message will be displayed and the chip will not be
programmed. If the security fuses are blown in a FAL or a GAL, the
data read from the chip will be all 1's or 0’'s regardless of what the
content is.

Current ADDR . BAAASRAS
Current Gang @ 1

Environnent

Whbe ¢ EALAML

EPE&T. ?'He i
——————— Repeat ﬁ?ﬁﬁiﬁﬁ% ga' ; 28
CHECK ﬁeﬁ%‘t B

(T TA VA Use AlE-U or K or ||

FEATI SR rrmmlmm-mmmmm{.nm_

Figure 4.4 Read Menu (PLD)
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If the chip is Rom or Single chip the data between the start address
and the end address will be read into the buffer. The address being
programmed will be displayed and the message will be displayed in
the section of "message"

L _Tils  Bujte

ip et ” oa0eng
& | gagons

ifi 4 Fead OK! gel Qtari ' AR
ank-Chack g f fer End ¢ HHHLFF
ata-Conpare

1to Current ADDE | AAALFS AR
Current Gany @ |
BULroane it —-

Tt 2t
il hie
HECKSUN : oopa

Figure 4.5 Read (ROM / Single)
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3. Verify

This compares the content of the buffer and the content of the chip.
If an error occurs, it displays the error message and the address
where it failed. If the chip is a ROM of Single chip, It verifies between
the start address and the end address. The address being verified
will be shown in the screen, being increased.

| file Burfer Hanufactwrer B - HAC o lBlls; 0310 ]
mm—&ﬂ :

FUWC 1 ons ﬁ 554 '
: FESULT © SUCCESS Lt
4 b  BoRar

W Leriication OK Eif Et o ! gag?g?%g

Eﬁta{w‘w
to

Current ADDR | ABB1FFOH
Current Gang
Enuwunnem

27€EI jtd

Repeat

R

Count : 001 |HTNIIRIETEETEE

FTTelp To-Tunction select Fo-Edit b7-Hanufactuver Bo-lupe

Figure 4.6 Verificatlon
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4. Blank check

If reads the content of the data and compares it with the blank
characters. if the chip is not blank it will display the discrepancy with
the address. If the chip is a ROM or Single chip partial blank check is
possible by Indicating the start and end address.

geys: palon |

IFHI31[I!!IIIIIIIF! i
JESULT © SUCLESS v Start

BaRHETE
Elank Check OK! B gE %t rt gg%?????

Current QDDR A0a1rTes
Curren ]
i nﬁlrnnnent
e M
AL

Bute

il
CHECKSUH : oone

Cmm .BM | Use Alt-U or ¥ or k|

tl-Halp Fo-Function select Fe-Rdit t/-Nanufacturer f8-fype - |

Figure 4.7 Blank Check
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5. Data Compare

This menu only applies to the ROM's and single micro-controllers.
This is the same as "Verify" menu except that this will generate the file
which will contain all the differences between the data of the chip and
the buffer. After the execution of the menu of "Data Compare” the file
name, which is the name of a device selected, with the suffix of "cmp”
will be created in a current directory.

For example, if AMD 27256 has been selected in the softwre, the file
created will be 27256. cmp. The file called 27267. cmp can be
viewed in a regular editor and contain all the differences between the
data of the chip and buffer. Not like the "verify" it will not stop in the
first difference it encounters, but it will continue checking.

L tile Bubyer Hamiact

Tl t10ns Hessage
rooaty | FESULT | SUCCESS

a ;
ge & Tata Comparison OK! ey Sta
o an -Check ‘ 1 nd

Current ADDR | APALFFEA
Current Gany |

Euut1onhpnt -
R’ES;
End ? ute

&4
CHECKSUM ; 0080
——————— Repeat

e B

....... Count © 001 |WETWEEINTE TR

b1-Halp Fo-Finctiop sel Fe-Ed L F/-Manufacturer fd-lupe

Figure 4.8 Data Compare
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6. Auto

This will execute many menus in a sequence. If the chip is a PAL or
Gal this will execute Erase, blank check, program, verify and security.

If any of the menu is interrupted by an error, the next step will not be
executed. If the chip is a ROM or Single chip this will execute Blank
check, Program, and Verify. For the series of 87 Single micro-
controllers encrypting is possible too.

W A
CLTON = rollT eSledess

lank Chggh 061 | Ff (|

{i |
Lemhca T, B Current ADDR  AARITERA
Current Gang |
Enulrgnm:m

Eef‘i“‘ '886

Cmm ol Use ALL-U or R or k|

] ﬂ'amﬂmmmml:ﬂu.ﬂmmm:m | Qs e

Figure 4.9 Auto
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7. Security

It the security bit is programmed the chip will be recognized as a
blank chip. Also, programming will not be possible. The security
function will apply only to PAL’s and GAL's.

TOhctTons : 'e séqe s
E‘ro:{ran FESULT

e
gﬂ{h hack

1458 Currevit ADDR : AAAAGASA
futo : Current Gang ; |1

L Lils Bufrer HapuFactiver WIATTOE - gaus: 9albn |

VLT 0nant

TR
I: Bute

EEEE%I 335%95 ;

 Use A1¢-U or R or k|

tltele tootunction select JO Lo P Ronioeirer T taee
Figure 4.10 Security
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8. Encryption program

This only applies to single chips. This will program the content of the
encryption table onto a chip. The content of the encryption table can
be loaded, saved and edited.

Once the data of encryption is written the data in the main buffer will

be Exclusive NORed with the data in the encryption table. If there is
an error, an error message will be displayed.

gous ; naleh

ﬁmjm‘l FESULT ! SUCEESS £ TPy : Eaggg

Encryption OK! S _EHBBBEI .
g?:mfx-check 2 guffer End ! annaa%??

Ruia-cmmre
0 Current ADDE | AARAAAAA

lmnm- Current Gang © 1
Sacurity Environneit

K T
A | i

CHECKSUH  © Foed

Figure 4.11 Encryption

9. MES Read

In GAL, Manufacturer's Electronic Signature contains the information
for the chip. The data other than the main data will be assigned to
the external buffer, and can be viewed through the menu, "Buffer ->
External Edit".
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B. Repeat

This determines the number of executions for a function to be
repeated.

ST = aihs
5 gl e Xt e |
kit bl S | |

ito Curcent ADDR | AABAABAR
ncraption Lurrent Gang . 1
ecurity m Enmfwnt
e+ SIEL

‘é yte

T

CHECKSUH  © Feeo

bl-talp Io-function select Fo-Bdit F/-Mawifacturer FB-Typs — o ]
Figure 4.12 Repeat

1. Repeat

Users can determine the number of repetitions.

2. Delay

When users repeatedly use "Function Select" to program the same
kind of devices many times this sets the time for pause between
executions. In the pause a chip can be replaced.

3. Count

The count of chips programmed will be displayed
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C. Message

The message for success or failure will appear.

D. Address

i
g?:hiﬂcheck

Eaia-cohnare
It

ncryption
BCUPLtY

Repoat

B ]

Cnun

 Use Blt-Uor R or k|

: 4
Eh%? \ ~?d,; E
BHEFS; Enir‘ :
Current ADDR

Curren{ Gang il
\?L‘erHHQ‘M R —

HFEE 5 INTE

CHECKSUM © Foee

Iﬂ'ﬂl’.b‘ﬂmmm-ﬂt _ -tﬂ.mmmm:-rn_
Figure 4.13 Address

1. GAL

In programming GAL, this will show the number of fuses and pins of
the chip in question, and it will show the current address which is
being read, verified, compared, and etc. Also, the number of gangs
selected will be shown.
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2. ROM

In programming ROM'’s or Single microcontrollers, the entries in the
address box will be displayed as explained below.

2.1 Chip Start

The address in the chip where programming will start will be
designated.

2.2 Chip End
The end address where programming will stop will be designated.
Hexa decimal values will be input. The address bigger than the last
address of a chip will not be accepted.
2.3 Buffer Start Address
The Start address of the buffer to be programmed will be designated.
2.4 Buffer End Address
The last address of the buffer to be programmed will be designated.
The address increment and the number of gangs will be shown as in
programming GAL's.
E. Environment
The information such as check sum, the number of gang selected,
the way of byte splitting for programming, the name of a

manufacturer and the part name of the device selected will be
displayed.
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2. Gang & Word Format

This menu determines the number of gangs and the type of word
format. The word format command will configure the way of
retrieving the data in the current buffer. The number following the
capital G In the menu is the number of gangs selected. There is an
optional four socket adapter for purchase. This is based on the
assumption that users use the four socket adapter. The four socket
adapter will program each gang serially.

Disk space !

Fi-Halo F5-tunction selact F6-Edif tr=Hamifacturer t8-lups

Figure 4.14 Gang & Word Format
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A. G1-Byte

This is for one gang and programs a byte (8 bits) at a time.

B. G1-Even Word

It is used for one gang and processes two bytes (16 bits) at a time.
Since "Even" is indicated it will program the even bytes. The
definition of the even byte will be explained as below.

(Example)

Given:

Address of Buffer Data of Buffer
Qo 01

01 23

02 45

03 67

04 89

05 AB

06 | cD

Result after programming :

Address of Chip Data of Chip
00 01

01 45

02 89

03 CD
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C. G1-Odd word

It is used for one gang and process 2 bytes (16 bits) at a time. Since
"Odd" is selected it will program the odd bytes. The example is as

follows.

(Example)
Given:
Address of Buffer
00

01

02

03

04

05

06

07

Result:

Address of Chip
00

01

02

03

4.18

Data of Buffer
01

23

45

67

89

AB

CD

EF

Data of Chip
23
67
AB
EF
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D. G1-Double word 0

This Is used for one gang and processes 4 bytes (32 bits) at a time.
This will program the data of the buffer in the addresses of Oth, 4th,
Bthy...o and so on.

(Example)

Given:

Address of Buffer Data of Buffer
00 01
01 23
02 45
03 67
04 89
05 AB
06 CD
07 EF
08 FE
09 DC
0A BA
0B 98
0oC 76
Result:

Address of Chip Data of Chip
00 01
01 89
02 FE
03 76
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E. G1-Double word 1

This is used for one gang and processes 4 bytes (32 bits) at a time.
This will program the data of the buffer in the addresses of 1st, 5th,
gth, ..... and so on.

(Example)

Given:

Address of Buffer Data of Buffer
00 01
01 23
02 45
03 67
04 89
05 AB
06 CD
07 EF
08 FE
09 DC
0A BA
0B 98
0C 76
Result:

Address of Chib Data of Chip
00 23
01 AB
02 DC
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F. G1- Doubie word 2

This is used for one gang and processes 4 bytes (32 bits) at a time.
This will program the data of the buffer in the addresses of 2nd, 6th,
10th, ..... and so on.

(Example)

Given:

Address of Buffer Data of Buffer
00 01
01 23
02 45
03 67
04 89
05 AB
06 CD
07 EF
08 FE
09 DC
0A BA
0B 98
oC 76
Result:

Address of Chip Data of Chip
00 45
01 CD
02 BA
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G. G1-Double word 3

This is used for one gang and processes 4 bytes (32 bits) at a time.
This will program the data of the buffer in the addresses of 3rd, 7th,
11th, ..... and so on.

(Example)

Given:

Address of Buffer Data of Buffer
00 01
01 23
02 45
03 67
04 89
05 AB
06 CD
07 EF
08 FE
09 DC
0A BA
0B 98
oC 76
Result: 7

Address of Chip Data of Chip
00 67
01 EF
02 98
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H. G2-Byte

This is used for two gangs and processes one byte (8 bits) at a time.
The same data from the buffer will be programmed for the two
gangs. When users read in this mode only the first gang will be read

and the data read will be loaded onto the buffer.

functions will be executed in both gangs.

l. G2-Word

But every other

This is for two gangs and processes two bytes (16 bits) at a time.
The even data will be programmed in the first gang, and the odd data
will be programmed into the second gang.

(Example)
Given:
Address of Buffer
00
01
02
03
04
05
06
07

Result:

Address of Chip
00

01

02

03

Data of Buffer
01

23

45

67

89

AB

CD

EF

Data of Gang 1
01

45

89

CD

Gang 2

23
67
AB
EF
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J. G3-Byte

This is for three gangs and processes one byte (8 bits) at a time. All
the functions except "read" will be applied to each gang. When users
read in this mode only the chip in the first gang will be read and
loaded into the buffer. All the three gangs will be programmed with
the same data.

K. G4-Byte

This is for four gangs and processes one byte (8 bits) at a time. All
the functions except "read" will be applied to each gang. When users
read in this mode only the chip in the first gang will be read and
loaded into the buffer. All the four gangs will be programmed with
the same data.

L. G4-Word

This is used for four gangs and processes two bytes (16 bits) at a
time. the even bytes will be programmed onto the first and the third
gangs, and the odd bytes will be programmed onto the second and
fourth gangs.

All the functions except "read" will be applied to each gang. When
users read in this mode only one chip in the first gang out of four
gangs will be read and loaded into the buffer. As the result of
programing the first and the third gang will receive the same data,
and the second and the fourth gang will receive the same data.
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(Example)

Given:

Address of Buffer

00
01
02
03
04
05
06
07

Result:

Address
of Chip

00
01
02
03

Data of Buffer

01
23
45
67
89
AB
CD
EF

Data of Chips in

Gang 1
01

45

89

CD

Gang 2
23
67
AB
EF

M. G4-Double word

Gang 3
01

45

89

CD

Gang 4
23
67
AB
EF

This is used for four gangs and processes 4 bytes (32 bits) at a time.
The first byte will be programmed in the first gang, second byte in the
second gang, third byte in the third gang, and fourth in the fourth.
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(Example)

Given:

Address of Buffer Data of Buifer
00 01
01 23
02 45
03 67
04 89
05 AB
06 CD
07 EF
08 FE
09 DC
0A BA
oB 98
oC 76
oD 54
Result:

Address Data of Chipsin
of Chip  Gangt Gang2 Gang3 Gang4

uo 01 23 45 67
01 89 AB CD EF
02 FE DC BA 98
03 76 54
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5 TEST

The SUPERPRO can test logic IC and RAM memory devices and
vector testing. A menu-driven software program provides an easy
interface for loading files, editing test patterns, and downloading test
files to the device. TTL.LIB Contains the TTL and CMOS test patterns.
The following checklist shows the steps required to test the Logic IC
and RAM’s. Each step is explained in detail In this chapter. To test
logic ICs and RAM memories, be certain that the SUPERPRO
hardware is properly installed, and that the programmer Is turned on.

Menu Options are selected from the main menu by typing in a key
letter on the keyboard. Each option will be described below.

at!ern
Test
aﬁto flnd device
Henory test
Uector test

—— fddress —

qorifhne !
irn jlel
a C}I 1le:? -....-..‘. ................

e [ fiy ?35?&;%5";

Figure 5.1 Test
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1. Edit Pattern

This option is used to edit a test pattern in the library of pattern files,
TTL. LIB. By specifying the directory or highlighting and pressing
<return> a buffer with the test pattern selected will show-up In the
upper left corner of the screen. The Following edit keys are used for
editing existing test pattern for the device selected;

The reserved key "Ctrl-F1" will bring out this menu from any menu and
any time.

Vv : VCC pins

G : GND (Ground) pins

X - Used in power pins, Output values will not be
tested (Vcc, Gnd)

H : Output Logic High (Voh)

L : Output Logic Low (Vol)

C : Clock pins

1 : Input Logic High (Vih)

0 : Input Logic Low (Vil)

Arrow : Left, right,up or down

Ctrl-N : Moves the cursor to the required address

PgUp : Page Up

PgDn : Page Down

Home : Go to the beginning of the line

End : Go to the end of the line

Ctrl-Home : Go to the beginning of a screen
Ctrl-End : Goto the end of a screen

Ctrl-PgUp : Go to the beginning of the buffer
Ctri-PgDn : Go to the end of the buffer

TAB : Toggles between ASCII and HEX fields
<Return> : first position of next line

ESC : Exits buffer

2. Append Pattern

To test a new device that is not included in the TTL.LIB, a new test
pattern must be created. There are two ways to create new test
patterns.

The first is to use the Append Pattern option from the menu. A new
test file will be created in addition to the existing TTL.LIB files. All the
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user-created test patterns are stored in the new test file. The data
format for the new test file is the same as the TTL.LIB files.

The alternate method is to create the test pattern flle using a
standard ASCII text editor or word processor. With this method, the
new patterns may be added to the TTL.LIB, or stored in a new test
pattern file.

Please refer to the section "Edit Pattern" for detailed explanations on
editing keys.

The reserved key "Ctrl-F2" will bring out this menu from any menu and at
any time.

3. Delete Pattern

This option allows the users to delete a pattern file from the library of
test pattern files, "TTL.LIB". Either type the name of a device in the
box provided or <return>, to display ali the patterns and select by
highlighting an entry. '

The reserved key "Ctri-F3" will bring vut this menu from any menu and at
any tine. .

4. TTL & CMOS Test

This option tests TTL or CMOS logic devices according to the test
pattern stored in TTL.LIB or in user-created files. Enter the device
type, such as 7400 and press Enter to begin the test. A message,
indicating pass or fail, will appear after testing.

The reserved key "Ctri-F4" will bring out this menu from any menu and at
any time.
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CHAPTER 5

5.Auto Find Device

This command finds out the device type of an unknown device. The
program will search through either TTL.LIB or the user-created data
file to find the matching pattern. The device type Is displayed for the
matching patterns ; a message "Device Not Found" Is presented if
there is no match.

The reserved key "Ctrl-F5" will bring out this menu from any menu and at
any time.

6. Memory Test

This option tests static and dynamic RAM memory devices. A list of
memory devices is displayed then select a type and press Enter to

perform the test.

The reserved key "Ctri-F6" will bring out this menu from any menu and
any time.

7. Vector Test

This performs the vector testing for GAL's and PAL’s. If error occurs
the message will display. A vector file will be loaded automatically if it
is included in a JEDEC fuse map file.

The reserved key "Ctri-F7" will bring out this menu from any menu and at
any time.
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6 MACRO

This makes a macro file and a batch file for automation. A macro file
would be created by the sequence of menu selections between the
BEGIN and END period of the menu. The menu selected and
executed will be memorized by the program and assigned to a
special function key specified by the user prior to the beginning of
the macro making. After the macro file creation, by pressing the
function key users can repeat the memorized sequence. After a
macro file is loaded, the file name is displayed in the lower middle
corner of the main screen. To stop the execution of a macro file
press Ctri-Break.

B
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Figure 6.1 Macro
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CHAFTER 6

1. Begin

In Superpro making a macro file is done by actual key code pressed
during the period which is partitioned by this menu and the "END"
menu. If this menu Is selected then a box will be displayed asking
what key would be assigned for a macro file which is about to be
created.

The reserved key "Alt-C" will bring out this menu from any menu and any
time.

2. End

This indicates the end period of the macro file making.

The reserved key "Alt-Q" will bring out this menu from any menu and at
any time.

3. Load

When this menu is selected, a box will ask for a macro file name to
be loaded.

The reserved key "Alt-F3" will bring out this menu from any menu and at
any time.

4. Save

This saves the macro file created under the name specified by an
user.

The reserved key "Alt-FG" will bring out this menu from any menu and at
any time.
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5. Batch Make

Instead of assigning a sequence of executions to a function key,
users can assign the sequence to a batch file and run It as soon as
the program is invoked. Follow the steps below.

1. Select the menu, "Macro->bAtch make”. A box for a batch file
name will be displayed.

2. Specify a name for the batch file and press the return key. A
message, "Press <Alt-Q> to end Macro" at the bottom line of
the screen is displayed.

3. Start selecting menus and execute the necessary steps.
4. Press Alt-Q to end the batch file making.

5. Go to the menu, "Option->Environment-> bAtch file name" and
press the return key to specify the batch file just created.

6. Next time as soon as the software is invoked, the batch file will
run.

Note: Users can set up the time delay between the executions by selecting
"Option->Environment->maCro delay time" and specifying the amount
of time to be delayed.

63



7 OPTION

This menu deals with optional settings such as port address change,
directory change, all the optional menu settings, and user-setup-
configurations.
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Figure 7.1 Option
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CHAPTER 7

1. Interface Port

This selects a port address to match the jumper sefting in the
interface card. The normal jumper position is port 5 and its equivalent
HEX value is 280 HEX. If the port settings for the interface and the
software are not matching, "Communication Error" message will be
displayed.

Librar
Algori

Figure 7.2 Interface Port

2. Directory
This specifies the directory where the LOPS files and libraries are.

Sub menus ;

System directory
Library directory

Note: It is mandatory that after the installing of Superpro in a directory,
the name of the directory name should be entered in this menu.
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3. Environment

This sets up the environment for automatic saving, multiple loading
and the default blank characters.

Sub menus ;

HEX Load Method
Blank Char
Multiple Load
Batch File Name
Macro Delay Time

3.1. Hex Load Method

This applies to HEX files. "Sequence" is used to load files with
sequentially increasing addresses, and "Random" Is used for the files
without sequence. If you use the wrong option the suggestion will be
displayed.

3.2. Blank Char

This sets the standard characters for the default blank characters. In

general, the default state is FF but for the 8748 series the default
state is 00. Only 00 and FF are acceptable.

3.3. Multiple load on

This mode should be on whenever a user deals with binary files and
wants to load many small files in the different locations of the buffer.

3.4. Batch File Name

If there is a batch file name set as soon as the program Is invoked the
batch file will be executed.
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3.5. Macro Delay Time

On executing a macro file this gives the specified amount of the
delay between unit executions.

4. Load Configuration

This menu will load the file called lops.cfg which has all the
information about the company, chip type and name, port address,
and setups for all the option menus.

5. Save Configuration

This menu will save the file called lops.cfg which records all the

information about the manufacturer, chip type and name, port
address, and setup for all the option menus.
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A JEDEC FILE FORMAT

XELTEK's SUPERPRO software and hardware are fully compatible
with the JEDEC file format. The JEDEC file format Is a standard
data format between data preparation systems, and programmable
logic device programmers.

The standard was developed to prevent the proliferation of data
transfer formats that occurred with microprocessor development
systems. The focus of the standard is on field programmable
devices and their support tools. It is not intended for other types of
semi-custom logic devices, or other types of fabrication or testing
equipment.

The format was developed by the Solid State Products Engineering
Council, and is published by the Electronics Industries Association.

The 18-page JEDEC document includes sections on speclal
notations and definitions, transmission protocol, data fields,
comment and definition fields, device programming flelds, device
testing fields, programmer /tester options, and examples.

To obtain a copy of the JEDEC file format, contact:
Electronic Industries Association
Engineering Department
2001 Eye Street, N.W.
Washington, D.C. 200086

The fee as of 1986 was US$11.00.
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B HEX FILE FORMAT

1. INTEL Format

A. INTEL 1 : 16 bit address field format, for files 64K bytes In
length or less.

DATA RECORD

Byte 1 Header=colon(:)
2.3 The number of data bytes in hex notation.
4.5 High byte of the record load address
6..7 Low byte of the record load address
8.9 Record type, must be "00"
10..x The data bytes in hex notation:
x=(number of data bytes-1)*2+11.

X+1.x+2 Checksum in hex notation.
X+3.X+4 Cartiage return, line feed

END RECORD
Byte 1 Header = colon(:)
2.3 The byte count, must be "00".
4.7 Transfer-address (usually "0000").
8.9 Record type, must be "01".
10..11 Checksum in hex notation.
12.13 Carriage return, line feed.

The checksum are the two complements of the 8-bit sum without the

carry of the byte count,and the transfer address. It will be "FF" if
above format is followed.
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B. INTEL 2 : MCS 86 format, using a 20-bit address for files larger
than 64K bytes.

DATA RECORD
Byte 1 Header = colon(:)
2.3 The byte
4.5 High byte of the record load address.
6.7 Low byte of the record load address
8.9 Record Type, must be "00".
10..x The data bytes in hex notatlon:

x=(number of data bytes-1)*2+11.

x+1.x+2 Checksum in hex notation
X+3.X+4 Carriage return, line feed

EXTENDED ADDRESS RECORD
Byte 1 Header = colon(:)
2.3 The byte count, must be "02".
4.7 Load address, must be "0000".
8.9 Record type, must be "02".
10..11 High byte of the offset address
12..13 Low byte of the offset address
14..15 Checksum in hex notation.
16..17 Carriage return, line feed

The checksum are the two's complement of the 8-bit sum without
carry of the byte count,offset address, and the record type.

START ADDRESS RECORD
Byte 1 Header = colon(;)
2.3 The byte count, must be "04".
4.7 Load address, must be "0000".
8.9 Record type, must be "03".
10..13 8086 CS value.
14.17 8086 IP value.
18..19 Checksum in hex notation.
20.21 Carriage return, line feed.
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2. Motorola Format

A. Mortorola S1 : this is the 16-bit address field format, for files
64K bytes in length of less.

DATA RECORD

Byte 1.2
3.4

N,
X oo

X+1.x+2
X+3.x+4

END RECORD

Byte 1..2
3.4

Header = "S1".

Byte count = number of data bytes + 3,
in hex notation.

High byte of the record-load address.
Low byte of the record-load address.
The data bytes in hex notation:

X =(number of data bytes1)*2+10.
Checksum in hex notattion.

Carriage return, line feed

Header = "S9".
Carriage return, line feed.

B. Mortorola S2 : This is the 24 extended address fleld format,
for files greater than 64 Kbytes in length.

DATA RECORD

Byte 1.2
3.4

5.6
7.8
9.10
11.x

X+1.X+2
X+3.X+4

Header = "S2" (24 bit address field)

Byte count = the number of data bytes + 4,

in hex notation.

High byte of the 24 bit record-load address.
Middle byte of the 24 bit record-load address.
Low byte of the 24 bit record load-address.
The data bytes in hex notation:

X =(number of data bytes-1)*2+12.
Checksum in hex notation.

Carriage return, line feed.

The byte count in data records includes the load-address and the

checksum.
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END RECORD
Byte 1..2 Header = "S9".
3.4 Carrlage return, line feed.

The checksum for any record is the one’s complement of the 8-bit
sum, without carry of the byte count, the load address, and the data
bytes. '

COMMENT OR SIGN-ON RECORD

Byte 1 Header = "S0".
2.X+1 Message up to X characters.
X+2.X+3 Carrlage return, line feed.

C. Mortorola S$3 : This is the 32 extended address field format,
for files greater than 64 Kbytes in length.

DATA RECORD
Byte 1..2 Header = "S3" (32-bit address field).
3.4 Byte count = the number of data bytes+5,
in hex notation.
5.6 High byte of the 32-bit record load address.
7..10 Middle byte of the 32-bit record load address.
1148 Low byte of the 32-bit record load address.
13.% The data bytes in hex notation:
x=(number of data bytes-1)*2+14.
X+1.X+2 Checksum in hex notation
X+3.x+4 Carriage return, line feed.

The byte count in data records includes the load-address and the
checksum.

END RECORD
Byte 1..2 Header = "S9".
3.4 Carriage return, line feed.
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The checksum for any record Is the one’s complement of the 8-bit
sum, without carry of the byte count, the load address, and the data
bytes.

COMMENT OR SIGN-ON RECORD
Byte 1 Header = "S0".
2.x+1 Message up to x characters.
X+2.x+3 Carriage Return, line feed.

3. Tektronix Format
A. Tektronix Format
DATA RECORD

1 Header = slash (/).
High byte of the record-load address.
Low byte of the record-load address.
The number of data bytes in hex notation.
The first checksum in hex notation;
it Is the sum of the load-address
and the number of data bytes.
10..x The data bytes in hex notation:
x=(number of data bytes-1)*2+11,
X+1.x+2 The second checksum in hex notation;
it is the 8-bit sum modulo 256 of the
data bytes.
xX+3 Carriage Return.

e
io'-q?.n'oa"gt

END RECORD

Header = slash (/).

Transfer address.

The byte count, must be "00".

Checksum in hex notation; it is the sum of the
transfer-address and the byte count.

10 Carriage Return

® o0
‘-D"~l(.‘|'lQ
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ABORT BLOCK

Byte 1 Header = slash (/).

2 Slash (/).

3.x+2 Message up to 69 characters:
x = number of characters.

X+3 Carriage Return.

All checksums are used in the Textronix format are computed as the
8-bit sum module 256 of the 4-bit hex digits that make up the bytes.
That is, the checksum is the sum of the upper and lower nibbles of
each byte.

B. Extended Tektronix Format

DATA RECORD

Byte 1 Header = "%"

2.3 Block length. Numbe: of characters
in the record, minus thie "%"

4 Record type Data record = "6"

5.6 Sumcheck. A 2-diqgit hex sum module

256 of all the values in the record
except the "%" and the sumcheck itseif

7.X Load address. Determines where the object
code will be located. A variable length number
that may contain upto 17 characters.
The first number determines the address fength,
with a zero 9 signifying a length of 16.

X+1 Obiject code, 2 characters per byte
END RECORD
Bytet Header = "%"
2.3 Block length. Number of characters
in the record minus the "%"
4 Record type. End record = "8"
5.6 Sumcheck. A 2-digit hex sum modele 256 of

all the values in the record except the "%" and
the sumcheck itself.



C CUSTOMER SUPPORT

This appendix contains Customer Support information, including the
Software Registration Card, the XELTEK Customer Support
department for technical assistance, Information on the License
Agreement, the limited one-year warranty, the 30-day money-back
warranty, and the one-year software service with fee.

1. Registration

Complete the card and return it to XELTEK, to become eligible for the
following:

. Customer support, warranty service, and technical assistance.
. Notification of any new products or special offer.

Registration is particularly important if the program was purchased
from a dealer or distributor, or through your purchasing department.
Why not take a moment right now to complete the card?

2. Calling Customer Support

XELTEK software has been designed to require a minimum of
technical support. The programs come with a comprehensive,
indexed Reference Manual. If you cannot find the answer in the
manual, you can turn to your dealer, distributor, or to XELTEK.

XELTEK provides free telephone technical assistance during normal
business hours (8:00 am to 5:00 pm, Pacific Time). Have your
invoice or purchase number ready when calling, as we cannot
answer your questions without it. To help us serve you better, please
review the following check list prior to placing your call:
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Pre-Call Check List

If you're having difficulty understanding the program, have you
studied the manual? The Reference Section of the manual
explains the program and design language details in even
greater depth.

If there seems to be a problem with the software, can you
reproduce it?

If the program has displayed an error message, please write
down the message.

When calling in for technical assistance, have your invoice
number ready.

Be familiar with the hardware configuration you're using. We
may need to know the brand;/model of your computer, the
total amount of memory availabie when starting up the
software, your graphics adapter, your printer brand/model,
and version of the disk operating system (DOS).

If possible, please call our Customer Support department
while you are at your computer. Be prepared to repeat the
sequence of steps leading up to the problem.

3. License Agreement

The purchaser is granted a non-exclusive license to use the program
on a single computer, subject to the terms and restrictions set forth
in this Agreement. This license is not a sale. The copyright of the
programs and Reference Manual remain the property of XELTEK.

You may:

c-2

Copy the programs for back-up purposes ONLY in support of
their use on a single computer.

Transfer the program from computer to computer, provided
that it is not operated on more than one computer at a time.

Transfer the program and license to another party If the other
party agrees to accept the terms and conditions of this
Agreement. If you transfer the program, you must at the same
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time either transfer all copies to the same party or destroy any
copies not transferred.

You may not:

Use this product in a computer system or network which
allows the program to be operated by more than one user at a
time.

Use, modify, copy or transfer the Reference Manual or other
documentation or any copy thereof except as expressly
provided in this Agreement.

Reverse engineer, decompile or disassemble any program
module or security device.

This license is effective until terminated. You may terminate it by
destroying or returning the program, reference manual, and all
copies thereof. This license will terminate if you fail to comply with
any term or condition of this Agreement.

4. Limited Warranty

XELTEK warrants that its products will be free from defects in
workmanship and materials, and shall conform to specifications
current at the time of shipment, for a period of one year from date of
shipment. During the one year period, any defective software or
hardware products will be repaired or replaced, at Seller's option, on
a return to factory basis. (For details, see Return/Replacement
Procedure below.)

This warranty applies only to products properly installed and
operated within specified environmental conditions.

XELTEK's responsibility under this warranty does not apply to (a) any
products which have been repaired, worked upon or altered by any
person not duly authorized in writing by XELTEK; or (b) any product
which has been subject to misuse, negligence or accident or whose
serial number has been altered, defaced or removed; or (c) any faults
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induced into the program by physical damage to the diskette or to
the corruption of the program by electronic or electrical interference.

All efforts have been made to verify the proper operation of the
software and the accuracy of the Reference Manual. XELTEK does
not warrant that the operation of the program will be uninterrupted or
totally error free.

New features and enhancements to the existing programs may be
added, and verified program faults or necessary amendments will be
rectified through the issue of periodic software revisions, notice of
which will be mailed 1o buyers of software updates service only.
Failure to return the completed Software Registration Card with
correct mailing address will exclude the purchaser from
automatically receiving notification of revisions to the program.
Software uptades and revisions will be subject to a fee.

XELTEK does not accept liability for any damages, including loss of
profit or savings, other incidental or consequentlal damages arising
out of the use, or the misuse or inabllity to use the program.

This warranty to repair or replace products not conforming thereof,
is specifically in lieu of all other warranties expressed or implied
including, without limitation, the warranties of merchantability and
fitness for use. No agent or representative of XELTEK has any
authority to bind XELTEK to any affirmation, representation, or
warranty concerning products made by XELTEK : and XELTEK will
have no liability whatsoever for any damage, loss, cost or expense
(whether direct, special or consequential) suffered or incurred by
buyer if products fail to conform with XELTEK's warranty herein.

5. 30-Day Money-Back Guarantee

XELTEK product is sold with a 30-day money-back guarantee. If you
are not completely satisfied with the package, return it to the place of
original purchase within 30 days of receipt for a complete refund of
your purchase price. See Return/Replacement Procedure below for
instructions on how to return the product.
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6. Return/Replacement Procedure

Under its Warranty, XELTEK agrees to replace defective diskettes,
documentation or units for up to one year from the time of dellvery.
The replacement materials will be supplied at no charge, providing
they are verified to be defective through no fault of the user. A
reasonable cost for materials and return freight will be charged to
replace materials defective through the fault of the user, for which the
one year warranty period has expired.

Under its Money-Back Guarantee, XELTEK agrees to accept for
return, and refund its software and hardware products for up to thirty
(30) days from the time of delivery.

The Buyer must obtain prior approval and a- Return Materlal
Authorization (RMA) number from XELTEK before returning any
product to XELTEK. The entire package, including software,
hardware, documentation, discount coupons, and any other items
supplied, must be returned intact. This guarantee will not be
honored for packages that are not returned complete and intact.

When you mail a unit for repair or refund, please be sure to have the
following information included with the product: the RMA number,
the invoice and purchase order of copy, and the description of the
problem. This will expedite the process of repairing and refunding.
Also, have your RMA number visibly written outside of the box.

Transportation and insurance charges to XELTEK’s facllity shall be
paid by the buyer. Transportation and insurance charges from
XELTEK's facility to buyer’s facility of equipment repaired or replaced
will be paid by XELTEK. XELTEK will ship the above repaired items
via a method similar to the one that Buyer used to return the
defective equipment.



D SELF MAINTENANCE

COMMUNICATION & TRANSISTOR TEST

Note: This test only works with all the port address. The
default address is the fifth jumper which is 280 HEX.

Testing

1. Set up your SUPERPRO as if you are programming, but
switch up the lever without any chip In the DIP socket.

2. Find out about the model of your programmer and the
jumper position of the interface card.

3. Invoke the test software for the universal programmer
which is designed to test both Unipro and Superpro. The
main menu Is as follows.

A. Communication Check

B. Transistor Check

C. Change Mode: Two selections are avallable - Unipro
and Superpro

D. Change Port: Eight selections are available - 1. 200H,
2. 220H, 3. 240H, 4. 260H, 5. 280H, 6. 2A0H, 7. 2COH,
8. 2EOH.

E. By selecting the option 4 match the port address of the
software and the card.

F. By using the option 3, select the model.

G. After the port address and the model have been set,
select the option number 1, and press the return key.
This will check the communication of the PCB of the
programmer and the test result will be displayed.

4. Next, mount the "testor’, which is the array of 33 (ohm)
resistors, and pull down the lever to lock the chip in the
socket. Select the option number 2 of the menu. If you
don't have the "testor”, you can make one. Tne lowest
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left pin will be connected with all other pins in the 40 pin
dip socket through one 330 ohm resistor In each path.

Repairing
For example, if the results read "TRQ 2 ERROR?",

1. Open the programmer.

2. You will see rows and columns of the transistor (looks like
semi-circle-cylinders standing).

3. Locate the Q2 and replace it. There are only two kinds of
transistors: 2N 4401(NPN), and 2N 4403(PNP).

4. Test Unipro again following procedure A.

These procedures will solve 65% of problems assuming
you have updated software. If you have further questions,
please contact the division of technical support at (408) 745-
7974 or (800) 541-1975.
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